Azure::Error::’targetFramework’ attribute currently references a version that is later than the installed version of the .NET Framework

Parser Error Message: The ‘targetFramework’ attribute in the element of the Web.config file is used only to target version 4.0 and later of the .NET Framework (for example, ”). The ‘targetFramework’ attribute currently references a version that is later than the installed version of the .NET Framework. Specify a valid target version of the .NET Framework, or install the required version of the .NET Framework.

compilation targetFramework

Solution:

Change following node to 4.0 web.config -> <system.web>:

<compilation targetFramework=”4.0″ />
<httpRuntime targetFramework=”4.0″ />